<img height="1" width="1" src="https://www.facebook.com/tr?id=188095848408072&amp;ev=PageView &amp;noscript=1">
Home | lync, Skype for Business, Polycom | Still using Lync phone edition devices? You better read this

Still using Lync phone edition devices? You better read this

    

 

Ahhhh fond memories. I recall with much joy the first time I deployed Lync Phone Edition (LPE) devices, all those years ago (not that long ago: 2010 to be precise). In the Lync world, for many years these were the only devices you could deploy for end users, meeting rooms or common areas where a physical handset was a requirement.

Picture7
 
How times have changed.

The approach Microsoft took to providing devices that natively registered to Lync was simple: Microsoft provided the code (known as Aries, which ran on Windows CE 6.0), and vendors (Polycom, HP, Aastra) provided the functional phone components around it: Microsoft controlled the software stack (responsible for support and updates), and the vendors looked after the rest. These devices were known as Lync “Optimized” devices. However, it soon became apparent that making phones was not core to Microsoft’s business, and there were plenty vendors out there that did it better. It was around the end of 2011 that we first began to see Compatible with Lync handsets from Polycom and others start to hit the market.

  

lync phone edition logo

 

As covered by Polycom’s Jeff Schertz here, Compatible with Lync handsets were devices that moved away from using a Microsoft provided and supported codebase, and towards using devices manufactured by 3rd parties that understood the finer nuances of telephony design. The software stack was owned and developed by each vendor, with each undertaking Third Party Interoperability Program (3PIP) certification before their devices were given the seal of approval from Microsoft to register against Lync. Looking at the broader ecosystem of 3rd party software and devices that integrate with Skype for Business, this was the model Microsoft moved forward with until recently, where we have begun to see the Microsoft developed and supported software stack start to take centre stage again, Surface Hub, Skype Room System, Microsoft Teams devices… (a topic for another blog…)

 

So, since 2011, we have had handsets available that were not based on Aries code which we could deploy to end users. LPE device support continued, with Support for LPE devices registering natively to Skype for Business Online also supported. This however will soon cease to be the case.

 

The Discontinuation of Support for TLS 1.0 and 1.1 in Office 365

As outlined here, Microsoft is dropping support for Transport Layer Security (TLS) versions 1.0 and 1.1 in Office 365 from October 31st 2018.

Why is this an issue you ask?

Windows CE 6.0 does not support anything above TLS 1.0. This is of course the underlying Operating System in use on LPE devices, so as of the end of October, if you have LPE devices, they will no longer be able to register against Skype for Business Online.

 

 

But I’m still using on-premises Lync/Skype for Business. Does this affect me?

If you’re still using on-premises Lync/Skype for Business infrastructure to support your end users, you have some wiggle room, but also take into account where your Exchange environment is. Are you using Lync/Skype for Business on-premises but Exchange Online? Your phones will sigh in, but any Exchange interop (voicemail, meeting invites etc) will cease to function. I would also add that it would be considered best practice to disable TLS 1.0/1.1 on your on-premise servers and enjoy added piece of mind of using a stronger security suite. Optional of course.

What devices are affected?

  • Polycom: CX500, CX600, and CX3000
  • Hewlett-Packard: 4110 and 4120
  • Mitel-Aastra: 6721ip and 6725ip

 

I Use On-Premises Lync/Skype for Business: How many LPE devices do I have?

A very good question, and I’m glad you asked. Luckily, the team at Insync Technology have put together a free tool that will tell you exactly how many LPE devices you have out there! So simple!

 

Picture1-2 

To use the tool:

Prerequisites

  • Must run from a Lync/Skype for Business Front End server
  • Must run tool as an administrator
  • Must have at least PowerShell 3.0 installed
  • User running it must have CSAdministrator rights

Using the Tool

  • Fill out the form below to download the executable
  • Copy to your Front End server and run as an administrator
Picture2-1
  • Read and Accept the terms and conditions

Picture3-2

  •  Click Run Check
Picture4-1

  

The tool will tell you how many Lync Phone Edition devices are registered against your Lync/Skype for Business Servers:

 

Picture5-1

 

Want help replacing with next generation devices?

Not sure what devices you need? Insync can help. Send us a consult request with a single click and we will be in touch. There are a number of offers from our friends at Polycom that you can take advantage of when replacing your LPE devices with next generation handsets that will continue to function with Office 365 past the cut-off date.

 

Picture6-1

 

Download the tool now:

 

 
Other Relevant links:

Polycom devices and Microsoft Teams 

Polycom devices FAQ

Insync Blog on TLS 1.0 

 

 

 

About the Author: Damien Margaritis

Picture of Damien Margaritis

Practice Manager – Modern Workplace

Get Notified! Subscribe for Blog Updates!

Insync

Isn’t it nice when things just work?

What does your organisation need to “just work”?

PLATFORMS

UNIFIED COMMUNICATIONS

IDENTITY

AUTOMATION
 

Still not sure what you need?

No problem! We can help.

CONTACT US